Back to overview
Resolved
Peer Nominations and Feedback are having issues
Jul 28, 2026 at 4:28pm UTC
Affected services
Wep App
Windy
Resolved
Jul 28, 2026 at 7:10pm UTC
We've restored all nominations and feedback. This is now resolved. Thank you for waiting.
Affected services
Updated
Jul 28, 2026 at 6:58pm UTC
We are continuing to work on restoring nominations and feedback and will post an update soon.
Affected services
Created
Jul 28, 2026 at 4:28pm UTC
We have implemented a fix and are working on restoring missing peer feedback and nominations. We'll send an update when it is complete.
Affected services