Back to overview
Degraded
Degraded Performance
Apr 24, 2026 at 7:00pm UTC
Affected services
Wep App
Resolved
Apr 24, 2026 at 7:25pm UTC
Experienced excessive load, and additional resources came online to resolve the slow performance.
Affected services
Created
Apr 24, 2026 at 7:00pm UTC
Some users may experience degraded performance on the Windmill platform. We have identified the root cause and are actively working on a fix.
Affected services