Back to overview
Degraded
Slow Response Times in Windy
Apr 15, 2026 at 2:10pm UTC
Affected services
Windy
Integration Syncing
Resolved
Apr 15, 2026 at 10:37pm UTC
The underlying root cause has been resolved and Windy should be responding normally.
Affected services
Updated
Apr 15, 2026 at 3:40pm UTC
We are still experiencing delayed response times. We are working on resolving and will continue to provide updates.
Affected services
Created
Apr 15, 2026 at 2:10pm UTC
We are currently experiencing delays in our queues resulting in slow Windy response times and slower than expected integration syncing.
Affected services