Back to overview
Degraded

We’re currently experiencing issues

Oct 20 at 04:28am EDT
Affected services
Wep App
Windy
Integration Syncing

Resolved
Oct 20 at 06:05pm EDT

Issues have been resolved on AWS' end, but we are continuing to monitor the situation

Updated
Oct 20 at 03:23pm EDT

We are still experiencing intermittent issues related to network traffic into us-east-1. We are monitoring the situation and awaiting resolution from AWS.

Created
Oct 20 at 04:28am EDT

Some parts of Windmill are affected due to a widespread AWS outage impacting multiple services. During this period, users may have experienced degraded performance or temporary unavailability in certain workflows.