Back to overview
Degraded

Degraded Performance due to Global Outages

Jun 12 at 03:11pm EDT
Affected services
App
Integration Syncing
Windy

Resolved
Jun 12 at 06:35pm EDT

Provider outages have resolved and service has returned to normal.

Created
Jun 12 at 03:11pm EDT

Due to global outages with AWS, GCP, we are experiencing degraded performance throughout the stack