Back to overview
Resolved
False notifications being sent out
Sep 14, 2026 at 8:27pm UTC
Affected services
Windy
Resolved
Sep 14, 2026 at 11:14pm UTC
The issue has been resolved. Approximately 2% of users were impacted and we have emailed everyone affected
Affected services
Updated
Sep 14, 2026 at 8:34pm UTC
We have resolved the issue and apologized for any confusion. We will reach out directly to anyone impacted by this issue
Affected services
Updated
Sep 14, 2026 at 8:29pm UTC
We have found the root cause and are pausing notifications momentarily
Affected services
Created
Sep 14, 2026 at 8:27pm UTC
Some customers with previously completed review cycles are receiving notifications from Windy. We are investigating the root cause and will reach out to anyone impacted directly
Affected services