Back to overview
Resolved

Degradation with Calendar and Meeting Syncing

Aug 19, 2026 at 3:02pm UTC
Affected services
Integration Syncing

Resolved
Aug 24, 2026 at 1:04am UTC

A fix has been released. Meeting syncing will gradually resolve over the next day.

Updated
Aug 19, 2026 at 9:01pm UTC

We're continuing to see improvements processing the backlog and are continuing to monitor.

Updated
Aug 19, 2026 at 6:37pm UTC

We're seeing improvements with our backlog. Meetings and calendars are processing at a faster rate. Our queues will take a couple hours to clear as we continue to monitor.

Updated
Aug 19, 2026 at 4:57pm UTC

We've deployed a mitigation and are continuing to monitor

Updated
Aug 19, 2026 at 4:01pm UTC

We're continuing to investigate and work toward a resolution.

Created
Aug 19, 2026 at 3:02pm UTC

We're experiencing delays syncing user calendars and meetings. Users may experience delays seeing these update in the platform. We're investigating this incident.